dotfiles/tmux/default.nix

39 lines
776 B
Nix

{ inputs
, lib
, config
, pkgs
, ...
}:
{
programs.tmux = {
enable = true;
keyMode = "vi";
mouse = true;
baseIndex = 1;
escapeTime = 20;
terminal = "tmux-256color";
historyLimit = 100000;
plugins = with pkgs.tmuxPlugins;
[
better-mouse-mode
catppuccin
];
extraConfig = ''
# Use catppuccin-mocha theme.
set -g @catppuccin_flavour 'mocha'
# Other catppuccin settigns.
set -g @catppuccin_window_default_text "#{window_name}"
# Don't leave gaps inDon't leave gaps in window numbers.
set -g renumber-windows on
# Vim keys for pane navigation.
bind h select-pane -L
bind j select-pane -D
bind k select-pane -U
bind l select-pane -R
'';
};
}